yum update를 하는데 갑자기 에러가 뜨네요.. > QnA

본문 바로가기
사이트 내 전체검색

회원로그인

30 일간 포인트 Top 10

dawn
3,510 Point
슈퍼7
3,280 Point
불량학생™
3,090 Point
아파치
2,790 Point
SK20031
2,680 Point
무와보
2,170 Point
도혁
2,150 Point
마젠토
2,150 Point
석호
2,110 Point
킵고잉
1,950 Point

접속자집계

오늘
244
어제
709
최대
709
전체
81,807
배너광고.

QnA

서버 yum update를 하는데 갑자기 에러가 뜨네요..

페이지정보

댓글 2 댓글

내용

염치 없지만 에러가 뜹니다. 

어찌 해결해야할지 몰라서 아파치님께 질문 드려봅니다. ^^;

[root@localhost ~]# yum -y update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
epel/x86_64/metalink                                                                                                                            | 8.3 kB  00:00:00
 * base: centos.mirror.moack.net
 * epel: mirror.premi.st
 * extras: ftp.kaist.ac.kr
 * remi-safe: ftp.riken.jp
 * updates: centos.mirror.moack.net
CodeIT                                                                                                                                          | 2.9 kB  00:00:00
base                                                                                                                                            | 3.6 kB  00:00:00
epel                                                                                                                                            | 4.7 kB  00:00:00
extras                                                                                                                                          | 3.4 kB  00:00:00
mariadb                                                                                                                                         | 2.9 kB  00:00:00
remi-safe                                                                                                                                       | 3.0 kB  00:00:00
updates                                                                                                                                         | 3.4 kB  00:00:00
(1/5): epel/x86_64/updateinfo                                                                                                                   | 987 kB  00:00:00
(2/5): extras/7/x86_64/primary_db                                                                                                               | 188 kB  00:00:00
(3/5): updates/7/x86_64/primary_db                                                                                                              | 3.4 MB  00:00:00
(4/5): epel/x86_64/primary_db                                                                                                                   | 6.7 MB  00:00:00
(5/5): remi-safe/primary_db                                                                                                                     | 1.4 MB  00:00:01
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick6-libs.x86_64 0:6.9.10.34-1.el7.remi will be updated
---> Package ImageMagick6-libs.x86_64 0:6.9.10.40-1.el7.remi will be an update
---> Package MariaDB-client.x86_64 0:10.3.13-1.el7.centos will be updated
---> Package MariaDB-client.x86_64 0:10.3.14-1.el7.centos will be an update
---> Package MariaDB-common.x86_64 0:10.3.13-1.el7.centos will be updated
---> Package MariaDB-common.x86_64 0:10.3.14-1.el7.centos will be an update
---> Package MariaDB-compat.x86_64 0:10.3.13-1.el7.centos will be updated
---> Package MariaDB-compat.x86_64 0:10.3.14-1.el7.centos will be an update
---> Package MariaDB-server.x86_64 0:10.3.13-1.el7.centos will be updated
---> Package MariaDB-server.x86_64 0:10.3.14-1.el7.centos will be an update
---> Package clamav.x86_64 0:0.101.1-1.el7 will be updated
---> Package clamav.x86_64 0:0.101.2-1.el7 will be an update
---> Package clamav-data.noarch 0:0.101.1-1.el7 will be updated
---> Package clamav-data.noarch 0:0.101.2-1.el7 will be an update
---> Package clamav-devel.x86_64 0:0.101.1-1.el7 will be updated
---> Package clamav-devel.x86_64 0:0.101.2-1.el7 will be an update
---> Package clamav-filesystem.noarch 0:0.101.1-1.el7 will be updated
---> Package clamav-filesystem.noarch 0:0.101.2-1.el7 will be an update
---> Package clamav-lib.x86_64 0:0.101.1-1.el7 will be updated
---> Package clamav-lib.x86_64 0:0.101.2-1.el7 will be an update
---> Package clamav-scanner-systemd.x86_64 0:0.101.1-1.el7 will be updated
---> Package clamav-scanner-systemd.x86_64 0:0.101.2-1.el7 will be an update
---> Package clamav-server-systemd.x86_64 0:0.101.1-1.el7 will be updated
---> Package clamav-server-systemd.x86_64 0:0.101.2-1.el7 will be an update
---> Package clamav-update.x86_64 0:0.101.1-1.el7 will be updated
---> Package clamav-update.x86_64 0:0.101.2-1.el7 will be an update
---> Package clamd.x86_64 0:0.101.1-1.el7 will be updated
---> Package clamd.x86_64 0:0.101.2-1.el7 will be an update
---> Package galera.x86_64 0:25.3.25-1.rhel7.el7.centos will be updated
---> Package galera.x86_64 0:25.3.26-1.rhel7.el7.centos will be an update
---> Package glibc.x86_64 0:2.17-260.el7_6.3 will be updated
---> Package glibc.x86_64 0:2.17-260.el7_6.4 will be an update
---> Package glibc-common.x86_64 0:2.17-260.el7_6.3 will be updated
---> Package glibc-common.x86_64 0:2.17-260.el7_6.4 will be an update
---> Package glibc-devel.x86_64 0:2.17-260.el7_6.3 will be updated
---> Package glibc-devel.x86_64 0:2.17-260.el7_6.4 will be an update
---> Package glibc-headers.x86_64 0:2.17-260.el7_6.3 will be updated
---> Package glibc-headers.x86_64 0:2.17-260.el7_6.4 will be an update
---> Package glibc-static.x86_64 0:2.17-260.el7_6.3 will be updated
---> Package glibc-static.x86_64 0:2.17-260.el7_6.4 will be an update
---> Package glibc-utils.x86_64 0:2.17-260.el7_6.3 will be updated
---> Package glibc-utils.x86_64 0:2.17-260.el7_6.4 will be an update
---> Package httpd.x86_64 0:2.4.38-1.codeit.el7 will be updated
---> Package httpd.x86_64 0:2.4.39-1.codeit.el7 will be an update
---> Package httpd-devel.x86_64 0:2.4.38-1.codeit.el7 will be updated
---> Package httpd-devel.x86_64 0:2.4.39-1.codeit.el7 will be an update
---> Package httpd-filesystem.noarch 0:2.4.38-1.codeit.el7 will be updated
---> Package httpd-filesystem.noarch 0:2.4.39-1.codeit.el7 will be an update
---> Package httpd-tools.x86_64 0:2.4.38-1.codeit.el7 will be updated
---> Package httpd-tools.x86_64 0:2.4.39-1.codeit.el7 will be an update
---> Package libargon2.x86_64 0:20161029-2.el7 will be updated
---> Package libargon2.x86_64 0:20161029-3.el7 will be an update
---> Package libssh2.x86_64 0:1.4.3-12.el7 will be updated
---> Package libssh2.x86_64 0:1.4.3-12.el7_6.2 will be an update
---> Package mod_http2.x86_64 0:1.10.12-1.codeit will be updated
---> Package mod_http2.x86_64 0:1.14.1-1.codeit will be an update
---> Package mod_ssl.x86_64 1:2.4.38-1.codeit.el7 will be updated
---> Package mod_ssl.x86_64 1:2.4.39-1.codeit.el7 will be an update
---> Package php-composer-semver.noarch 0:1.4.2-2.el7.remi will be updated
---> Package php-composer-semver.noarch 0:1.5.0-1.el7 will be an update
---> Package php-composer-spdx-licenses.noarch 0:1.5.0-1.el7.remi will be updated
---> Package php-composer-spdx-licenses.noarch 0:1.5.1-1.el7 will be an update
---> Package php-ioncube-loader.x86_64 0:10.3.2-1.el7.remi.7.2 will be updated
---> Package php-ioncube-loader.x86_64 0:10.3.4-1.el7.remi.5.4 will be an update
--> Processing Dependency: php(api) = 20100412-64 for package: php-ioncube-loader-10.3.4-1.el7.remi.5.4.x86_64
--> Processing Dependency: php(zend-abi) = 20100525-64 for package: php-ioncube-loader-10.3.4-1.el7.remi.5.4.x86_64
---> Package python.x86_64 0:2.7.5-76.el7 will be updated
---> Package python.x86_64 0:2.7.5-77.el7_6 will be an update
---> Package python-libs.x86_64 0:2.7.5-76.el7 will be updated
---> Package python-libs.x86_64 0:2.7.5-77.el7_6 will be an update
---> Package python-zope-component.noarch 1:4.1.0-3.el7 will be updated
---> Package python-zope-component.noarch 1:4.1.0-5.el7 will be an update
---> Package python2-future.noarch 0:0.16.0-6.el7 will be updated
---> Package python2-future.noarch 0:0.16.0-7.el7 will be an update
---> Package tzdata.noarch 0:2018i-1.el7 will be updated
---> Package tzdata.noarch 0:2019a-1.el7 will be an update
---> Package uwsgi.x86_64 0:2.0.17.1-1.el7 will be updated
---> Package uwsgi.x86_64 0:2.0.17.1-2.el7 will be an update
---> Package uwsgi-plugin-common.x86_64 0:2.0.17.1-1.el7 will be updated
---> Package uwsgi-plugin-common.x86_64 0:2.0.17.1-2.el7 will be an update
--> Finished Dependency Resolution
Error: Package: php-ioncube-loader-10.3.4-1.el7.remi.5.4.x86_64 (remi-safe)
           Requires: php(zend-abi) = 20100525-64
           Installed: php-common-7.2.14-1.el7.remi.x86_64 (@remi-php72)
               php(zend-abi) = 20170718-64
           Available: php-common-5.4.16-46.el7.x86_64 (base)
               php(zend-abi) = 20100525-64
Error: Package: php-ioncube-loader-10.3.4-1.el7.remi.5.4.x86_64 (remi-safe)
           Requires: php(api) = 20100412-64
           Installed: php-common-7.2.14-1.el7.remi.x86_64 (@remi-php72)
               php(api) = 20170718-64
           Available: php-common-5.4.16-46.el7.x86_64 (base)
               php(api) = 20100412-64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

지우고 다시 설치하는게 좋을까요..?

댓글목록

둘리세상 의 댓글

no_profile 둘리세상 쪽지 보내기 메일보내기 프로필 아이디로 검색 전체게시물 kr 본문 글쓴이 IP (39.♡.151.137) 날짜

[root@localhost ~]# yum --skip-broken update
[root@localhost ~]# yum -y install yum-skip-broken
[root@localhost ~]# yum clean all
[root@localhost ~]# yum -y update
[root@localhost ~]# yum remove  php-ioncube-loader-10.3.4-1.el7.remi.5.4.x86_64
[root@localhost ~]# yum -y --enablerepo=remi,remi-php72 install php-ioncube-loader
[root@localhost ~]# yum clean all
[root@localhost ~]# yum -y update

이렇게 해서 해결했습니다.. ^^.. 감사합니다.

GNUBOARD_M
Copyright © 아파치존. All rights reserved.